Facing Problems while working with AICSImage package for CZI files

Hi All,

I am working with LLSM movies as CZI files. The movies have 3 channels and are pretty large so I am using delayed image reading from the AICSImage package. The code is as follows.

I am trying to access one time point and one channel at a time. The code works perfectly with channel 2 but sort of disrupts the movie for channel 1 and 3. I have attached screenshots of the actual movie in czi format and the movie in ome.tiff format in fiji.

It also displays the dimensiosn for channel 2 and channel 1 and 3 as being different

when i run the code img.dims I get
<Dimensions [T: 130, C: 3, Z: 116, Y: 2052, X: 340]>

However when I run the code
lazy_t0 = img.get_image_dask_data(“CZYX”, T=1,C=2)
t0 = lazy_t0.compute()
I get Z: 114, Y:2048, X:337 (this happens only for channel 1 and 3)

The complete code is here

lazy_t0 = img.get_image_dask_data(“ZYX”, T=1,C=2)
t0 = lazy_t0.compute()

Save the array as OME-TIFF

with tifffile.TiffWriter(output_tiff_file_path, bigtiff=False) as tif:
tif.write(t0, photometric=‘minisblack’, metadata={‘axes’: ‘ZYX’})

Hello @dnadeem57 and thanks for the question.
In the future please put questions about aicsimageio or bioio in the image.sc forum instead as that is our preferred and primary support forum.

If there is any way you are able to share the image then we would be able to debug this on our end to understand exactly what’s happening. You can contact me directly or also post it as an issue in aicsimageio’s github.

My best guess is that it might be newer CZI data or is stored in a way which our czi reader library is not yet supporting. The code you pasted here looks ok.

Hi @danielt,
Thanks for responding. I can share the data with you. Can you give me an email where I can share the link to the dataset?

I sent a dm with email address or you can just reply to the DM alternately.

Hi @dnadeem57,

I saw that you actually had posted on image.sc forum prior to posting here. Somehow we missed your post there - I’m sorry! I’ll double check our notification system.

Hope your issue has been resolved.