Allen Cell Discussion Forum

Errors with running the demo of the Classic Image Segmentation


I’ve been having some issues with the classic image segmentation demos. No matter which of the three kernels I have that are currently available to me, I cannot get it to run because the libraries are not downloading.

This error is produced with the Python3 interpreter and the Python[conda env: segmentation]* interpreters:

This error is produced with the Python[conda env: root] kernel: No module named itkwidgets. (Sorry, new users can only post one image…).

Anyone have any hints into getting this to work?


I would be happy to help. First of all, I would like to know more about the details.

I assume segmentation is the environment you installed aicssegmentation? If so, under the segmentation environment, can you try pip show aicsimageio and pip show tifffile and post the output here?

Also, just FYI. I just found some recent update of tifffile, aicsimageio, aicsimageprocessing cause some version conflict. We just made an update.

You may try this out? (basically, git pull in your local repo, then re-install the package.)


1 Like

I think this worked!!!
I’m no longer getting those errors :slight_smile: well timed update, thank you!

Hi there, I’m experiencing similar version conflicts when installing the machine learning version segmenter. Upon a fresh install, I got the error:
ERROR: aicsimageio 0.6.4 has requirement tifffile==0.15.1, but you’ll have tifffile 2020.6.3 which is incompatible.

If I revert to tifffile==0.15.1, I receive another error:
ERROR: scikit-image 0.17.2 has requirement tifffile>=2019.7.26, but you’ll have tifffile 0.15.1 which is incompatible.

I had a similar problem when installing the classic segmenter a last week, but with a fresh install today, it seems to be fixed. Maybe the machine learning version needs a similar update to account for the new versions? (Could also be something wrong on my end of course - I tried to be careful following the installation instructions!)

Great thanks for your feedback. There is indeed a dependency version issue. It has been fixed. See this

Could you give it one more try? Let me know if there is any issue.


Wow, thank you for the rapid response and update! I think that fixed it - I’m no longer getting errors for dependency conflicts during installation of the machine learning version.

Glad to hear. Feel free to leave a message if there is any bug, issue or question. Would be happy to help.


Hello there again!
Uh…I’m not sure where this error is coming from now. Any ideas?
It kind of just appeared one day last week; I haven’t changed the code and redownloaded just to make sure it wasn’t me having accidentally altered something.


it look like a dimension problem. Is your image single channel or multilple channel? 2d or 3d?

or you can simply try IMG.shape, which will tell the size of your image.


It’s 3-D (so I’d figure 3 channels) but for whatever reason, the only number that will output any result is 0.
Is this a feasible number to use?
I apologize for so many questions; I’m still an undergrad :sweat_smile:

Can you try IMG.shape?

Look like your image is a single channel 3d image. So, only channel 0 works

Ohhhhhhh. Ok, thank you!

Hi there!

So I’m fresh installing again on another computer but I’m coming across this error; I’m assuming this means there was a change in that import? With a fresh install, it should have the most recent updates, right?


Sorry for the inconvinience. We are in the process of cleaning up the code to accommendate new aicsimageio API. For now, the easiest solution will be switching to the ‘dev’ branch after cloning the repo, then install the ‘dev’ branch. Let me know if more help is needed.


hi @mramsahoye, we just deployed a new version which cleans up the issue you encountered. If you update your local repo, everything will be updated and should work now. Let me know if you have any more questions.


1 Like

Thanks so much for the fast reply!!