Allen Cell Discussion Forum

Error when running Look Up Table Demo Classic Image Segmentation

Hi all,

Very new to coding, and attempting to install and run the Allen Classic Image Segmentation. The installation went smooth until the very last step, Step 3.3 Test Segmenter. Here is the error I get:

(segmentation) C:\Projects\aics-segmentation\lookup_table_demo>jupyter notebook, choose anaconda installer.
Traceback (most recent call last):
File “C:\Users\elcid\anaconda3\envs\segmentation\Scripts\jupyter-script.py”, line 10, in
sys.exit(main())
File “C:\Users\elcid\anaconda3\envs\segmentation\lib\site-packages\jupyter_core\command.py”, line 247, in main
command = _jupyter_abspath(subcommand)
File “C:\Users\elcid\anaconda3\envs\segmentation\lib\site-packages\jupyter_core\command.py”, line 134, in _jupyter_abspath
‘Jupyter command {} not found.’.format(jupyter_subcommand)
Exception: Jupyter command jupyter-notebook, not found.

Any help would be greatly appreciated. Jupyter Notebook (anaconda3) is installed

Best,
Aidan

just to make sure.

can you post the exact command you are running?

Hi Jainxu,

Sorry about leaving that out. Here you go:

(segmentation) C:\Projects\aics-segmentation>cd C:\Projects\aics-segmentation\lookup_table_demo

(segmentation) C:\Projects\aics-segmentation\lookup_table_demo>jupyter notebook, choose anaconda installer.
Traceback (most recent call last):
File “C:\Users\elcid\anaconda3\envs\segmentation\Scripts\jupyter-script.py”, line 10, in
sys.exit(main())
File “C:\Users\elcid\anaconda3\envs\segmentation\lib\site-packages\jupyter_core\command.py”, line 247, in main
command = _jupyter_abspath(subcommand)
File “C:\Users\elcid\anaconda3\envs\segmentation\lib\site-packages\jupyter_core\command.py”, line 134, in _jupyter_abspath
‘Jupyter command {} not found.’.format(jupyter_subcommand)
Exception: Jupyter command jupyter-notebook, not found.

(segmentation) C:\Projects\aics-segmentation\lookup_table_demo>

Two things that may be of note. If I simply type the command “jupyter notebook” it does indeed open up the Jupyter Notebook App in my browser. I am then unable to type any longer in my anaconda prompt which now indicates it is a jupyter notebook. In addition, according to the git.hub instructions, when installing the packages, this is the command: cd ~/Projects/aics-segmentation

When I include the “~” this command returns an error, but if I leave it out it works. Not sure if that is important as I get the packages to install without issues when leaving out the “~”.

Thanks,
Aidan

Looks like you are running this?

Can you try just jupyter notebook ?

Jianxu

That’s correct, and when I run “jupyter notebook” (sorry for the quotes, I’m not sure how to make commands appear as code format, the jupyter notebook browser app does indeed open and I can open, among other things, the Look Up Table Demo. Also, I can no longer type in the Anaconda prompt and it indicates it is a jupyter notebook (I’m not sure if this is normal).

Thanks for the help.

Aidan

this is a video demo of how to use this tool. Hope this can clear up all the puzzles. let me know if you have more questions :smile:

Jianxu

Great, thank you for the help!